It is evident that a new image is downloading, but the update does not take place.
Please send a video. Thank you!
Update for two apps
After ssh logging into the machine, execute
docker images | grep forgejo
docker ps -a | grep forgejo
Let me see what the reason for the failure of the reconstruction container is.
journalctl -u zimaos-app-management.service --no-pager | rg -i 'failed to update compose app|failed to start|container.*start|error|unhealthy'
logs.txt (15,8 КБ)
I think the key question should be
Error response from daemon: Conflict. The container name \"/forgejo\" is already in use by container \"420963ef900fff48b737c50a3c0d2b47f87cb61a4475e25dd6f96f3a8b72856e\". You have to remove (or rename) that container to be able to reuse that name.
Can you try to delete the container_name: forgejo field and save it?
Finally, thank you for your patience in helping us troubleshoot the problem.
Fof forgejo it helps, but for youtrack - such error
Aug 13 09:53:57 ZimaCube-Pro zimaos-app-management[2179]: 2026-08-13T09:53:57.784+0300 error failed to start original compose app {"func": "service.(*ComposeApp).up", "file": "/home/runner/work/ZimaOS-AppManagement/ZimaOS-AppManagement/service/compose_app.go", "line": 749, "error": "Error response from daemon: failed to set up container networking: driver failed programming external connectivity on endpoint youtrack-server-1 (693b487e2c19b24a9a49d7c5cf4b397c96638024a664f90de1265b324474f336): Bind for 0.0.0.0:60830 failed: port is already allocated", "name": "youtrack"}
Is port 60830 occupied by other applications or containers? How about trying to modify the port? Or let me see your yaml
Port 60830 is used by the application being updated.
services:
youtrack:
cpu_shares: 90
command: []
deploy:
resources:
limits:
memory: 62.54GB
reservations:
devices:
- capabilities:
- gpu
device_ids:
- "0"
placement: {}
entrypoint: null
image: jetbrains/youtrack:2026.2.17765
labels:
icon: https://upload.wikimedia.org/wikipedia/commons/8/85/YouTrack_icon.svg
network_mode: bridge
ports:
- target: 8080
published: "60830"
protocol: tcp
privileged: true
restart: unless-stopped
volumes:
- type: bind
source: /media/ZimaOS-HD/AppData/youtrack/conf
target: /opt/youtrack/conf
- type: bind
source: /media/ZimaOS-HD/AppData/youtrack/data
target: /opt/youtrack/data
- type: bind
source: /media/ZimaOS-HD/AppData/youtrack/logs
target: /opt/youtrack/logs
- type: bind
source: /media/ZimaOS-HD/AppData/youtrack/backups
target: /opt/youtrack/backups
x-casaos:
author: self
category: self
hostname: zimacube-pro.local
icon: https://upload.wikimedia.org/wikipedia/commons/8/85/YouTrack_icon.svg
index: /youtrack
is_uncontrolled: false
main: youtrack
port_map: "60830"
scheme: http
store_app_id: youtrack
title:
custom: youtrack
I reinstalled the app and updated it—the error is gone.
The problem only affects apps installed prior to the update to version 1.7.0.
Now the same error is happening with the forgejo as well.
Aug 20 13:35:00 ZimaCube-Pro zimaos-app-management[2174]: Container server-forgejo-1 Starting
Aug 20 13:35:00 ZimaCube-Pro zimaos-app-management[2174]: 2026-08-20T13:35:00.605+0300 error failed to start original compose app {"func": "service.(*ComposeApp).up", "file": "/home/runner/work/ZimaOS-AppManagement/ZimaOS-AppManagement/service/compose_app.go", "line": 749, "error": "Error response from daemon: failed to set up container networking: driver failed programming external connectivity on endpoint server-forgejo-1 (3db41433826669f4504214c2b86d2c3d43da4d6be77a17e2ca580f9c02e0c534): Bind for 0.0.0.0:2222 failed: port is already allocated", "name": "server"}
Aug 20 13:35:01 ZimaCube-Pro zimaos-app-management[2174]: 2026-08-20T13:35:01.606+0300 error failed to apply changes to compose app {"func": "service.(*ComposeApp).Apply.func1", "file": "/home/runner/work/ZimaOS-AppManagement/ZimaOS-AppManagement/service/compose_app.go", "line": 1112, "error": "Error response from daemon: failed to set up container networking: driver failed programming external connectivity on endpoint server-forgejo-1 (3db41433826669f4504214c2b86d2c3d43da4d6be77a17e2ca580f9c02e0c534): Bind for 0.0.0.0:2222 failed: port is already allocated", "name": "server"}
@MalginYury Are there multiple forgejo containers after the upgrade? According to the reason, docker compose will automatically create new containers and networks with aliases when upgrading.
Let’s see the complete output of docker ps-a?
Yes, a second container is created, while the first one continues to run.
Aug 22 10:45:04 ZimaCube-Pro zimaos-app-management[2174]: Container server-server-1 Starting
Aug 22 10:45:04 ZimaCube-Pro zimaos-app-management[2174]: Container server-forgejo-1 Starting
Aug 22 10:45:04 ZimaCube-Pro zimaos-app-management[2174]: Container server-server-1 Started
Aug 22 10:45:04 ZimaCube-Pro zimaos-app-management[2174]: 2026-08-22T10:45:04.832+0300 error failed to start compose app {"func": "service.(*ComposeApp).SetStatus.func1", "file": "/home/runner/work/ZimaOS-AppManagement/ZimaOS-AppManagement/service/compose_app.go", "line": 1226, "error": "Error response from daemon: failed to set up container networking: driver failed programming external connectivity on endpoint server-forgejo-1 (7eb4b3a7ac0f4b97a84025c7493338e03592a04c83037bf172ff367aa154ee3b): Bind for 0.0.0.0:2222 failed: port is already allocated", "name": "server"}
docker.txt (11,8 КБ)




